PHP Warning: file_get_contents(): Unable to find the wrapper “https” – did you forget to enable it when you configured PHP?

By | March 20, 2013

Hey Folks,

Warning: file_get_contents(): Unable to find the wrapper “https” – did you forget to enable it when you configured PHP?

Got the above warning? No Problems. You can get rid of this warning by just enabling php_openssl.dll extension in your php.ini [For eg. xammp/php/php.ini] configuration file. [If you’re not seeing php_openssl.dll itself in your php.ini, just directly add the extension line to the php.ini configuration file]

Your php.ini file :

;extension=php_oci8_11g.dll
;extension=php_openssl.dll
;extension=php_pdo_firebird.dll

You just need to uncomment the line extension=php_openssl.dll.

It should look like below :

;extension=php_oci8_11g.dll
extension=php_openssl.dll
;extension=php_pdo_firebird.dll

If the extension itself does not exist, You have to add extension=php_openssl.dll to your php.ini file. (Provided you’ve the proper dll file bundled with your windows PHP environment (I’m using XAMPP & the dll extension is php_openssl.dll.)

Note : I’m using XAMPP for Windows

Cheers,
JENSon.

One thought on “PHP Warning: file_get_contents(): Unable to find the wrapper “https” – did you forget to enable it when you configured PHP?

  1. Bing

    Awesome, thank you! Much faster than what some of the other answers on Google were suggesting!

Leave a Reply

Your email address will not be published. Required fields are marked *